Lesson 2: The CAD
Environment

WELCOME!

This lesson is all about the CAD environment within PowerCivil. As discussed in the
previous chapter, PowerCivil is an integrated environment of powerful civil design tools
along with a very comprehensive CAD engine. In this lesson you will learn how to
navigate within the CAD environment as well as how to manage the data that is being
created during the design and production process. The use of some of the basic drawing
tools will be investigated as we prepare to begin the modeling process in the next lesson.

LESSON OBJECTIVES
In this lesson, the topics covered include:

e Topic 1 PowerCivil User Interface — menu bars and dialog boxes
e Topic 2 Managing Data Files — managing the various data types in the project

e Topic 3 Attaching a DWG Reference — how to attach a DWG as a reference to the
layout

e Topic 4 PowerCivil Drawing Tools — using basic tools to complete the layout

Be sure to have a look at the context sensitive help for PowerCivil. Either while using
the tutorial or in general practice with the software, you will find the help system not only
includes program documentation but it also is equipped with links to online video clips
(internet connection is required). Access the help from the menu bar under Help>Civil
Help.

INTRODUCTION

This Lesson will show you how the interface of PowerCivil is laid out, helping you to understand where
tools can be found and how to navigate the application. Additionally, you will learn about the key data
components for your design and production work. It is essential that you understand where items are stored
and how changes to your design should be committed to hard memory for later recall. Finally, you will
complete the geometric layout for this tutorial using some of the basic drawing tools provided with
PowerCivil.
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User Interface

USER INTERFACE

The PowerCivil user interface allows the user to choose a command either through the
menu bar or by selecting an icon from one of the various tool palettes.

From the desktop launch PowerCivil using the program icon @ navigate to the folder
for Lesson 2 and open the file “CAD_ENVIRONMENT.dgn”. Once the file is open, you
will want to explore the interface using the following:

To view this portion of the lesson, press the play button.

PLAY

Let’s take a look at the menu bar, where you will find many of the common Windows-
like selections as well as other menu options that are specific to PowerCivil.

CAD_Environment.dgn (3D - ¥8 DGN) - MicroStation PowerCivil 2004 Editi... B3

File Edit Element Settings Tools  Uklities  Workspace  Civil  Window Help

From the File menu, you can select from the typical Windows file operations as well as
others specific to PowerCivil.

CAD_Environment.dgn (3D - ¥8 DGN) - MicroStation PowerCivil 2004 Editi... B

File Edit Element Settings Tools Utilities ‘Workspace Civil Window  Help

M mew... Chrl+h
= Open... ChrlHo
Close Chrlhi
i save Ctrl45
Save fs...
Compress 3
Save Settings Chrl+F
Reference

Raster Manager

Models
Imnpork »
Expoark »

Prink Prewisw
S Prirk Chrl+P
Batch Prink

Associate. ..

Properties Alt+Enter

[ Protection 3
B Send...

Exit
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User Interface

The Edit menu also provides some typical Windows functions as well as those specific
to PowerCivil.

Edit Element Settings Tools Utilities

e Undo Cirl+7
Undo Other »
G Beda Cirl A
Set Mark
it c
v Cirl4
IR paste cirl+v

Paste Spedal...
Show Clipboard

@& Find/Replace Text

Select Al
Select None
Select By Attributes

Insert Object...
Update Links
Links. ..

Ghject

DIDE Links. ..

The Element menu is specific to PowerCivil and provides access to drafting element
dialogs for cell (block) placement, dimensioning, custom line styles, element tags, text
styles and element information.

Element Settings Tools Utilities
] Cells —
Dimension Styles
Line Styles >

Multidine Styles

Tags 3
Text Styles

Information  Ctrl+l

The Settings menu is also specific to PowerCivil and provides access to program settings
that control the behavior of the application. Key items are AccuDraw, Snaps, View
Attribute and the Level tools.

Settings Tools Utlites  Workspace

|7 Tool Settings
Manage
AccuDraw
Color Table...
Database 3
Design File...
Level 3
Locks 3
Rendering View Attributes
Snaps 3
View Attributes Cirl+B
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User Interface

The Tools menu provides access to PowerCivil tool palettes that can be docked into the
interface for quicker access to often used drafting tools. Key items to dock are Attributes,
Primary, Standard, Main and Common Tools.

Tools Utllities Workspace Civil  Window

|w attributes

'7 Primary

’T Standard
Main 3
Annotation 3

Auyiliary Coordinates
'7 Common Tools
Design History
Digital Signatures
Dimension Tools »
Drop
Engineering Links
Isometric
Multidine Joints
Raster »
Redline
References
Tags
View Control

Rendering Tools

Tool Boxes... Ctrl+T
Close Tool Boxes. ..

The Utilities menu provides access to other functions of PowerCivil that may not be used
as much but can still provide significant value to the user. Key functions to consider are
Key-in, Saved Views, Standards Checker and Data Cleanup.

Utilities  workspace  Civil  window

Eery-in

Connect Web Browser

Cell Gelector
Image »
Render »

Augiliary Coordinates
Saved views

Mamed Groups

Standards Checker 4
Packager. ..

Archive

Install Fonts. ..

Data Cleanup

Dimension Audit

Diiq »
License Check GukTn

Macro 3

MCL Applications
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User Interface

The Workspace menu provides access to operational settings within PowerCivil. These
settings control much of the environment that the user experiences while working. In this
tutorial we will adjust the Workspace Configuration so that the resources supplied with
the data set are found by the program automatically reducing the time spent browsing the

folder structure.
‘Workspace  Civil  Window

Preferences, .
Configuration, ..
Cuskornize

Function Keys...

Butkon Assignments. ..

About Warkspace

In addition, you may want to adjust the Button Assignments depending on the type of

mouse that you are using. Typically, the primary buttons on the mouse are assigned as
follows...

Button Assignments

Buttonz Invoked by o

Left Button
Tentative Middle Buttan
Reset Right Button Carcel
Command Al-Right Button _J
30 Data Alt-Left Buttan

Drefault

3D Tentative Alt-Left Button - Right Button Chord LI _—J

~ Button Definition Area

Press the button you want to uge for <Data> here
You can use the Alt key andfor a two-button chord

If you do not have a center button or mouse wheel, the Tentative button is invoked by a
Left-Right Button Chord. It is not necessary to configure any buttons beyond “Data”,
“Tentative” and “Reset”.

The Civil menu is primarily used to access the civil design capabilities which will be
discussed later in the tutorial.

Civil  Window  Help

| Civil Tools

User Preferences

Surwey

Digital Terrain Model
Maodeler

Drainage

Water & Sewer

Geornekry

Cross Sechion

2
Profiles »
2
Plans & Quantities 3

Tools »
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Managing Data Files

The Window menu provides access to the 8 views of PowerCivil. These views can be
oriented in many ways to make it easier to navigate the data in the file.

Window  Help |

| Yiews »
Cascade
Tile
Arrange

IT Scroll Bars

1 View 1
2 CAD_Environment.dgn (30 - w8 Dl - MicroSkation PowerCivil 2004 Edition
3 Element Selection

The Help menu provides access to the HTML based online help system that, in addition
to this tutorial, can also assist you as you work with PowerCivil.

The “Common Tools” palette (Tools>Common Tools) provides many of the drawing and
manipulation tools that will be used to create and edit the site layout. Experiment with
some of these tools to get familiar with them as they will be used extensively in the
ensuing lessons.

The “View Controls” located at the bottom left of each PowerCivil View allow you to
control the view aspects. With these controls you can zoom, pan, window an area, fit the
design and more. Experiment with the “View Controls” to get familiar with them as they
too will be used extensively in the ensuing lessons.

MANAGING DATA FILES

The management of design data while working with PowerCivil requires a bit of
forethought.

When dealing with the Site Modeler portion of the product, there are two primary data
types to consider, first there is the DGN/DWG design file which stores the CAD data.
Second, there is the PowerCivil Modeler project data which is saved as a file with the file
extension of GSF. These two files are very much interrelated and changes to either one
will have an impact on the other.

To keep order when dealing with Modeler design data, it is recommended that you name
the GSF file the same as the DGN file. This will help to ensure that the project data does
not get out of sync with the design file data. You will want to be in the correct DGN file
when the Site Modeler is invoked and a GSF file opened. Naming the two files the same
is the best way to ensure synchronization.

In addition, there are other data files that will be created as the project progresses. The
following is a list of data files that will be created during this tutorial...

-
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Attaching a DWG Reference

File Type Description

DGN Design file containing geometric layout, text and general information
used to produce plans

GSF PowerCivil Site Project file containing all components of the grading
model This file must remain synchronized with the corresponding DGN
file

GPK PowerCivil Coordinate Geometry file containing all geometry related to

horizontal & vertical alignments as well as stake out information

GDF PowerCivil Drainage Project file containing all components of the
drainage design

GWS PowerCivil Water and Sewer project file containing all components of
the water and sewer design

ATTACHING A DWG REFERENCE

In order to accurately design the drives and parking area for the commercial site, we will
need to reference in the surveyed topographical data for the project. In this case, we are
going to assume that survey was done by a firm that uses a product different than
PowerCivil and the firm has provided a file that is in DWG format.

As stated in the introduction, this format difference does not present a problem.
PowerCivil can easily reference the DWG file “BASE.DWG” to the master file
“LAYOUT.DGN?”,

To view this portion of the lesson, press the play button.

PLAY

Follow these steps to make the reference attachment:
1. Use File=Open to open the file “LAYOUT.DGN” from the lesson 2 folder.

2. Onceinthe “LAYOUT.DGN? file, access the “References” dialog
(File>References) or use the Primary Tool bar icon.

Primary Tools E
=5+ "
7 Qﬂ'l -2 -
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Attaching a DWG Reference

4,

?’ The CAD Environment

Cancel !
In the “DWG/DXF Units” dialog, set the “Units” to “Feet” and press the “OK”
button.

Hint

Tools  Settings

Slat | File Mame

E-lxaodesa s

aefs) e i
= |
| Model | Description

3. At the “References” dialog use the “Attach Reference” icon (Tools>Attach) to
open the “Attach Reference” dialog. Change the “List Files of Type” option to
“CAD Files” and navigate to the Lesson 2 folder and select “BASE.DWG” and

press the “OK” button.

On the Attach Reference dialog, select Directory>Current Work Directory to set

the folder to the same folder as the current design file resides in. This negates
the need to navigate to the folder when the files are in the same folder.
g References (0 of 0 unique, 0 displayed)

S E3

{Lie

| Logical

| ).% Hilite Made:  Boundaries 'l

| Presentation | 5] of| & |

£3 StartData
23 Video_Clips

Elle Directory
Files: Directaries:
| . Alesson_02-The CAD Environment',
base.dwg (= TN
CAD_Environment.dan (= data
layout. dgn [ Geo
[ Site
[ Commerciall

= Leszon_02-The CAD Enviranme!

4] |
iLis Dirirves: Attachment Method:
CAD Files [*. dan.* dwg * dx] ¥| Bc
™ Save Relative Path DWiE Dgtionsl

x| Interactive Vi

DWG/DXF Units
MicroStation V& requires that the file units be accurately specified in order for "True” scaling to be
following reason:

calculated correctly when working with cells and reference files. It is not possible to infer the units for the
DWG or DXF file: "C:\data\Geo'\Site\Commerdal 1\Lesson_02-The CAD Environment\base.dwg” for the

This file has linear units set to Decmal (LUNITS = 2). Itis not possible to infer the units for files with this

setting. If you know that the Design Center Units settings (INSUNITS) is correctly set for this file, using
this setting is recommended. The current setting for Design Center Units is "Unspecified”.

Units: _Feet Vi

[~ Do not display again [Uss this sefting for all DWG/DF files of this type)
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Drawing Tools

5. Accept the default settings on the “Reference Attachment Settings” by pressing
the “OK” button. The DWG base file will now be referenced (attached) to the
“LAYOUT.DGN" file.

Reference Attachment Settings for base.dwg

File Mame:  base.dwg
Full Path; .. \baze.dwg

il

Logical Mame: |
Description: | Aligred with Master Fils

Orientation:

| Description

Standard View
Frant Standard Wiew
Right Standard “iew
| sommetric Standard Wiew Li

Scale [Master: Ref] |1.DDDDD[ 5 |1.DDDDD[ ¥ Tie Scale

Mested Attachments: Mo Mesting vI [Depth: |‘I

[V Display Raster References

Ok I Cancel I Options... |

With the survey information attached, we can now see how the design layout corresponds
to existing conditions; we will use the drawing and modification tools to complete the
design. We can control the view of the DWG reference and finish the design edge of
pavement, making the design ready for modeling.

DRAWING TOOLS

One of the really nice things about PowerCivil is that the design features like grading and
drainage features are controlled by drawing elements. This may not seem like a big deal

on the surface, but the power to change design features by moving or modifying drawing
elements is truly awesome.

Since the grading will depend on the elements used to layout the commercial design, it
might be a good idea to get comfortable with some of the drawing and modification tools.

To view this portion of the lesson, press the play button.

PLAY

?’ The CAD Environment © 2005 Bentley Systems, Incorporated Do Not Duplicate

2-9



Drawing Tools

Follow the steps to complete the layout:

1.

Continuing in the “LAYOUT.DGN? file, use the “Level Display” dialog

(Tools>Level>Display) from the “Primary Tool” bar to turn “OFF” most of the

levels in the “BASE.DWG” reference. Right-click in the dialog and choose “Off By

Element” then click on the elements in the view which you do not wish to see.
c-@i1e

OEEREREE Ve <]
\@ I'Eéé %0 [none) » Levels ¥

= layout.dgn, Layout 2

Nurmber
Water
Vegetation
Storm Drain
Signs
Sidewalk
Setback Invert Selection
Sanitary ...
Road Cen...

O By Element
Retaining... All Except Element

Prop_ Lin...

Point Nu...

Point Ele... Level Manager
Point Des._.

Pavement.__ Properties

Choose the level “DesEofP” from the “Attribute” tool box and begin to construct the
driveway returns in the layout. Choose the “Construct Circular Fillet” tool to add the
returns to the road intersection.

_[I=)EPRPSE IR

Continue to construct the layout by extending the driveway intersection. Use the
key-in (Utilities>Keyin) command “Extend Line” and the “Construct Circular Fillet
tool to complete these tasks.

SUMMARY

The main points to remember are:

The user interface can be controlled and modified in various ways. You can access
commands through the menu bar or from tool palettes.

Managing data files is important — remember to keep naming conventions in order to
ensure synchronization between CAD and model data.

Referencing DWG data is a snap.
Drafting tools are available to produce layout graphics.

For more video instruction please visit the following web page...
http://65.217.17.142/downloads/sitemodeler/ GEOPAK%20Site%20Modeler%20Training%20Videos.htm
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