
Lesson 14: Design 
Reports 
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WELCOME! 
This lesson is about producing reports from the design data generated in the tutorial.   
Now that you have designed the commercial site, it is possible to extract information that 
can be utilized in plans production and the actual construction of the site.  In this lesson 
you will learn how to utilize the tools for producing design reports. 

LESSON OBJECTIVES  
In this lesson, the topics covered include: 

• Topic 1 Coordinate Stake-out – providing data for construction 
• Topic 2 Coordinate Table – providing coordinate tables 
• Topic 3 Geometry Reports – producing road centerline data 
• Topic 4 Standard Drainage Reports – standard drainage reporting 
• Topic 5 Custom Drainage Report – custom drainage reports using VBA 
 
Be sure to have a look at the context sensitive help for PowerCivil.  Either while using 
the tutorial or in general practice with the software, you will find the help system not only 
includes program documentation but it also is equipped with links to online video clips 
(internet connection is required).  Access the help from the menu bar under Help>Civil 
Help. 
 

INTRODUCTION 
This lesson will focus on extracting data from the Site Grading design we did using the 
PowerCivil Modeler program, PowerCivil Drainage Program, and PowerCivil Water 
Sewer program.  The data that we extract can be placed in the CAD file as a chart or 
table.  It can be sent to a data collector used by a survey crew in the field, or to another 
software program which may be used by the construction management team. 

From the desktop, launch PowerCivil from the program icon, navigate to the folder for 
Lesson 14 and then open the file “LAYOUT.DGN”.  

To view this portion of the lesson, press the play button. 

Once in the file, you will want to follow these steps: 

1. Open the Civil Tools (Civil>Civil Tools). 



Staking Out the Parking Lot 

 
2. Invoke the Modeler Tool (Civil>Modeler). 

 
3. Open the “GSF” file “LAYOUT.GSF” from the Lesson 14 folder. 

 

STAKING OUT THE PARKING LOT 
Let’s step through a procedure to create the necessary data to stake out the parking lot for 
our project.  We will stake out the edge of pavement for our parking lot.  We need points 
at various locations along the edge of the parking lot and the islands. 

1. Access the “Export to COGO” tool from the Modeler>Project>Export to 
COGO pull down menu. 

2. Fill in the dialog as shown: 

 
3. Press “Apply”. 

Now we will create points along the centerline of the south access road that we can use to 
set up an instrument and locate the parking lot edge of pavement points from. 
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Staking Out the Parking Lot 

 
4. Continuing with the “Export to COGO” dialog, make the changes as shown 

below: 

 
5. Click the “Select Element” icon at the top of the dialog and select the centerline 

of the “South Access” road and then click “Apply”. 

We now have several points that have been created in a coordinate geometry database 
(job123.gpk).  The database was created back in Lesson 7 when we designed the 
Roadways.  Now we are simply adding points to that database. 

Next, we will open the coordinate geometry database and draw the points into the file to 
see where they are. 

6. Open “Coordinate Geometry” using the icon from the Civil tools 
(Civil>Geometry>Coordinate Geometry). 
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Staking Out the Parking Lot 

 
7. Once the COGO dialog is present, we will set the visualization to “Permanent 

Visualization” and select the “Navigator” tool. 

      
8. Highlight all the newly created points and click the “Visualize Element” icon. 

 
The points are drawn into the file and can be reviewed graphically. 

 
The next step is to create a Staking Report.  To do this we will use a tool located in the 
Survey portion of PowerCivil. 
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Staking Out the Parking Lot 

 
9. Select the “Survey” tool from the Civil Tools (Civil>Survey). 

 
10. Tear off the “Plan Preparations” tool palette from the “Survey Tool Box”. 

 
11. Select the “Place Stake Table” tool. 

                             
12. Fill out the dialog as shown. 

 
To get the List of Points to Stake you will need to click the “Get Points from 
Navigator” icon and highlight all the points you want to add to the list in the 
dialog.  Once highlighted then click the “Get Points from Navigator” icon again 
to populate the list. 

13. Click the “Place” button and data point in the View 1 of the file to place a graphical 
representation of the table. 
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Stake out the Building 

 

STAKE OUT THE BUILDING 
For the building we will provide a coordinate table for the four corners.  The procedure 
will be similar to the parking lot. 

To view this portion of the lesson, press the play button. 

1. Use the “Export to COGO” tool (Modeler>Project>Export>To COGO) in 
Modeler to calculate points at the corners of the building element. 

 
Four points are created at each corner of the building. 
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Roadway Centerline Data 

 
2. Next, access the “Place Coordinate Table” tool located on the “Plans 

Preparations” tool palette. 

                     
3. Fill in the dialog as shown.  Highlight the four building points and click the 

Place button. 

 
The table can be placed into the file or an ASCII text file can be created that could be 
uploaded to a data collector.  Turn off Write to Output File to Place the table graphically. 

 

ROADWAY CENTERLINE DATA 
Turning our attention to Decab Street, we want to create a table with all the necessary 
geometry information for the centerline of the street.  The centerline alignment was 
created during Lesson 7 – Designing Roadways.   

To view this portion of the lesson, press the play button. 
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Roadway Centerline Data 

 
The following is a detailed description of the alignment geometry: 

Chain DECAB contains:                                                            
 10 CUR DECAB-1 CUR DECAB-2 11                                                   
Beginning chain DECAB description                                                
=====================================================  
Point 10               N      342,269.0640 E      338,424.3637 Sta      0+00.00  
Course from 10 to PC DECAB-1 N 89° 45' 35.03" E Dist 132.6798                    
                                   Curve Data                                    
                                  *----------*                                   
Curve DECAB-1                                                                    
P.I.  Station             2+02.31  N        342,269.9124  E        338,626.6732  
Delta       =      38° 23' 30.72" (RT)                                           
Degree      =      28° 38' 52.40"                                                
Tangent     =             69.6315                                                
Length      =            134.0129                                                
Radius      =            200.0000                                                
External    =             11.7747                                                
Long Chord  =            131.5199                                                
Mid. Ord.   =             11.1201                                                
P.C.  Station             1+32.68  N        342,269.6204  E        338,557.0423  
P.T.  Station             2+66.69  N        342,226.8980  E        338,681.4299  
C.C.                                        N        342,069.6222  E        338,557.8810  
Back        = N  89° 45' 35.03" E                                                
Ahead       = S  51° 50' 54.25" E                                                
Chord Bear  = S  71° 02' 39.61" E       
Course from PT DECAB-1 to PC DECAB-2 S 51° 50' 54.25" E Dist 184.7492                                                           
                                   Curve Data                                    
                                  *----------*                                   
Curve DECAB-2                                                                    
P.I.  Station             4+99.12  N        342,083.3158  E        338,864.2078  
Delta       =      26° 49' 06.12" (RT)                                           
Degree      =      28° 38' 52.40"                                                
Tangent     =             47.6806                                                
Length      =             93.6138                                                
Radius      =            200.0000                                                
External    =              5.6051                                                
Long Chord  =             92.7615                                                
Mid. Ord.   =              5.4523                                                
P.C.  Station             4+51.44  N        342,112.7702  E        338,826.7128  
P.T.  Station             5+45.06  N        342,040.1131  E        338,884.3811  
C.C.                                        N        341,955.4944  E        338,703.1639  
Back        = S  51° 50' 54.25" E                                                
Ahead       = S  25° 01' 48.12" E                                                
Chord Bear  = S  38° 26' 21.19" E                                                                                 
Course from PT DECAB-2 to 11 S 25° 01' 48.12" E Dist 293.0391                                                                            
Point 11      N      341,774.5944 E      339,008.3640 Sta      8+38.09                                                                          
=====================================================  
Ending chain DECAB description                                                   

To create a graphical table that can be placed in the file we can use a tool titled “Place 
Calls Table” located in the “Plans Preparation” tool palette. 

1. Access the “Place Calls Table” tool on the “Plans Preparations” tool palette. 
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Roadway Centerline Data 

 
2. Fill out the dialog as shown. 

                    
Set the “Table Format/Column Order”, the click the “Add Chain to Calls List” 
icon to populate the Calls List in the middle of the dialog. 

3. Highlight all items in the “Calls List” and Click “Place”.  Place the Table in the 
file and review. 

                                   

CREATE REPORTS FROM DRAINAGE DESIGN DATA 
We will look at a few ways to create reports from the Drainage Design we did in Lesson 
12 – Drainage Design.   

To view this portion of the lesson, press the play button. 

To get started we need to open the Drainage Project. 

1. Access the Drainage tools from the main menu Civil>Drainage and open the 
Drainage Project file “DRAINAGE.GDF”. 
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Roadway Centerline Data 

 
2. Select the “Set Active Network” tool and set the Network “Option 1” to be 

active. 

                                
Once the Network is active we can access several standard reports created by the 
software. 

3. Pull out the “Drainage Reports” tool frame from the main “Drainage Tool Box”. 

 
4. Click on each of the first 5 icons to bring up the standard reports.  The “Storm 

Drain Hydraulic Summary report” is shown below. 

                                
Each report can be saved off as an ASCII file.  There is a Highlight and Window 
Center option that allows you to navigate the system graphically in the file.  
There is a modify icon which will bring up the appropriate component dialog to 
make changes to the system. 
We can also create customized reports for use with another software package.  
For example we can extract certain drainage design data from the system in a 
user defined order and send it to an Excel spreadsheet. 

5. Click the “Drainage Report Builder” icon from the Drainage Reports tool frame. 
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Roadway Centerline Data 

 
6. From the “Report File” pull down menu in the dialog, select “Open” and select 

the “StormTab.drf” file from the lesson 14 folder. 

 
The StormTab.drf file is a saved off list of drainage data that we would like to 
report on.  The user would simply compile a list of report data and save it off to 
a drainage report file that could then be recalled on subsequent drainage 
projects. 

7. The dialog will populate as shown. 

 
8. Click the “View” button to create the “StormTab.csv” file and review it. 

CUSTOM REPORT OUTPUT EXAMPLES 
At this point there are various ways to create an Excel Spreadsheet in the format one 
would desire.  We will run a Visual Basic Application that takes the “StormTab.csv” file 
and creates a spreadsheet. 

To view this portion of the lesson, press the play button. 
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Roadway Centerline Data 

 
1. From the main menu, select the Utilities>Macro>Project Manager to activate 

the “VBA Project Manager” tool. 

 
2. Click the “Load Project” icon and select the following VBA Project. 

C:\Data\Geo\Site\Standards\StormSewerTab.mvba 

 
3. Highlight the “StormSewerTab.mvba” file in the Project Manager dialog and 

click the “Run” icon. 
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Roadway Centerline Data 

 
4. Next highlight the macro and click the “Run” button. 

 
5. Fill in the dialog as shown. 

 
6. Click the “Generate Report” button and when prompted for an Excel file name 

key in “StormTabulation.xls”. 
7. Use Windows Explorer and review the Excel file. 
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Roadway Centerline Data 

 
Now we will take a look at how we can use VBA to create a custom table that can be 
plotted in the design file along with a custom ASCII report. 

8. From the “VBA Project Manager” dialog, click the “Load Project” icon and 
select the following VBA Project: 

 
9. Click the “Run” icon and select the following macro then click Run. 

 
10. Fill out the “Drainage Structure Schedule” dialog as shown: 
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Roadway Centerline Data 

 
11.  Data point in blank location of the view to place a graphic table. 

 

SUMMARY 
The main points to remember are: 

• PowerCivil provides many ways to extract data from the proposed grading project 
and provide that information to the construction team. 

• Visual Basic Applications provide us a way to extend the program and data 
contained with in the program to many user defined applications. 

• You can create reports and/or extract information from PowerCivil into a usable and 
customizable format. 

 
For more video instruction please visit the following web page… 

http://65.217.17.142/downloads/sitemodeler/GEOPAK%20Site%20Modeler%20Training%20Videos.htm
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