Lesson 17: Quantity
Extraction

WELCOME!

This lesson is about extracting quantity information from the design data generated in the
tutorial. Now that you have designed the commercial site, it is possible to extract
information that can be quantified and used in the cost estimate for the actual
construction of the site. In this lesson you will learn how to utilize the tools for quantity
extraction.

LESSON OBJECTIVES
In this lesson, the topics covered include:

e Topic 1 Computing Quantities with Design & Computation Manager
e Topic 2 Creating a Pavement Design
e Topic 3 Exporting Quantities to various formats.

Be sure to have a look at the context sensitive help for PowerCivil. Either while using
the tutorial or in general practice with the software, you will find the help system not only
includes program documentation but it also is equipped with links to online video clips
(internet connection is required). Access the help from the menu bar under Help>Civil
Help.

INTRODUCTION

This lesson will focus on extracting data from the Site Design Layout, Drainage Design,
and Water Sewer Design for the purpose of computing quantity takeoffs. The quantity
computations can then be sent to another software program which may be used by the
construction management team.

QUANTITY EXTRACTION

From the desktop, launch PowerCivil from the program icon, navigate to the folder for
Lesson 17 and then open the file “LAYOUT.DGN".

To view this portion of the lesson, press the play button.

PLAY

-
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Quantity Extraction

Once in the file, you will want to follow these steps:
1. Open the Civil Tools (Civil>Civil Tools).

2. Invoke the “Design & Computation Manager” tool (Civil>Plans &
Quantities>Design & Computation Manager).

|Design & Compukation Manager

COMPUTE DRAINAGE QUANTITIES IN PLAN

Let’s step through a procedure to extract and compute the quantity of storm sewer pipe
and drainage structures (catch basins, grate inlets, pits, etc.) for our design.

1. Open the Drainage Project file “DRAINAGE.GDF ” from the Lesson 17 folder.

2. Access the “Drainage Nodes” tool frame (Drainage>Tool Boxes>Nodes) and
the “Drainage Links” tool frame (Drainage>Tool Boxes>L.inks).

Drainage Nodes =]
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|Update Modes with Pay Items
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|Update Links with Paw Items|

3. Click on the “Update All Nodes with Pay Items” icon and the “Update Links
with Pay Items” icon. This will redraw all pipes and nodes with the symbology
of the Design & Computation Manager Pay Item that they are linked to through

the drainage library.

-
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4. Returning our attention to the Design & Computation Manager dialog, we will
switch to the “Compute Mode”

gDesign and Computation Manager M= 3
File Edit Settings Favorites Help

O ERLE

@B CADatahGeohSitehstandardshsite. ddb
(23 Drafting Standards |Add Highlighted to the Collection
1 AREAS/SHAPES
(= Payltemn

23 W astewater Ltility
23 wiater Utility
23 Plan

g id

i Drainage

£ Mise

23 Drainage

5. Highlight the “Drainage” folder as shown and click the “Add Highlighted to the
Collection” icon.

6. On the “Plan Quantity Computation” dialog set it as shown and click the
“Compute Quantities” button.

g Plan Quantity Computation ME E
Job: 125 QA § ! Active DesignFile ¥| Inside |03

Bazeline Reference

Mohe vI

¥ Hilite During Computation vI Compute Quantities |

This will produce a report of the quantity of items in the Drainage folder that are
in the design file.

E Computation Results = B3

temn | Description | Quantity | Unit | Export I
F027-163-110 3% 3 Type 1 Giate [nlet 70000 EA
027-162-2040 RCP 24" Class |Il 342000 LF
027-162-2035  RCP 21" Class Il 209000 LF
027-162-2030  RCP 18" Class IIl 909.5000 | LF

Export Format: _[tem Report 'II Q,  Create Vl Enport I
Fur | Fhase: | DesignEstimate j Dizplay |

You will natice that the manholes were not counted because they were not
found. We will fix this and recomputed.

7. Open the Drainage Library and navigate to the “4’ Dia. MH” Item.
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8.

£ Drainage Library - __\geo\site\standards\drainagelibrary dib  [H[E

File  Edit

Highlight it and click the “Modify Library Item” icon.

ﬂainfalll Land Usel Nodes I Linksl Spread Seclion]

Mode Typez:  Junction b

Element 1D

4' Dia. MH ar M 3
4 % 4 Junction Box al

Description

|Mndify Library Item

2

9. The “Payltem” field is empty or set to None. We will add the appropriate
Payltem. Click the “Select Payltem” icon.
10. Navigate to the Payitem>Drainage>Manholes>027-163-310 4’ Diameter
Circular Manhole item and highlight it.
11. Click “OK”.
EDlainage Library - Hode Item M= E
Item ID: [ 4' Dia. MH oK.
Descriptior: | Circular Marnhole _I
Paplter: [027163-310 ﬂl
Criteria File: I Q Flan Yiew Cell
Plan View Cell: [MH2 Select..|
Mode Type:  Junction "l
12. Click “OK” on the “Drainage Library — Node Item” dialog.
13. Select File>Save on the “Drainage Library” dialog to save your changes.
14. Back at the “Drainage Nodes” tool frame, click the “Update Nodes with Pay
Items” icon to redraw all drainage nodes.
15. Go back to the “Design & Computation Manager”, switch to the compute mode
and recompute the drainage quantities. View the results.
£ Computation Results M= E3
[tem | Description | Quantity | Unit | Export I
027163110 313 Type 1 Grate Inlet 7.0000TEA =
027-1E63-310 A' Diamneter Circular b anhale 3.0000 E&,
0271622040 RCP 24" Class Il 342000 | LF
027-162-2035  RCP 21" Class Il 209000 | LF
0271622030 | RCP 18" Class Il 909.5000 | LF
Export Format: ke Report "II O Create Vl Export I
Fiuri | Fhases | DesignEstimate j Drizplay |
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CREATING A PAVEMENT DESIGN

We will now take a look at how to create and quantify a pavement design using the
Design & Computation manager.

To view this portion of the lesson, press the play button.

PLAY
1. Attach the “Saved View” (Utilities>Saved View) titled “Pavement Design”.

2. Open “Design & Computation Manager” (Civil>Plans & Quantities>Design &
Computation Manager).

3. Navigate to the “Payltem>Plan>Pavement Design>Pave Design 2 Pavement
Design — Tons” item and highlight it.
4. Right Click on it and select “Modify Item”.

£ Item Modify M= B
[tem 10 I Pave Dezign 2 b Diefault
Dezcription: I Pavement Design - T Drafting Standards

7 Compute Parameters
Placement: Favement Design k

Clazs:  Primarny
Cell Mame: I Set Scale vII 1.000

 Supplemental Search Criteria
v Levels: | a W |1z |

W Colors: [1112 |

Match |
¥ Stles [0 1
¥ wieights: [0 &1 Feset |

~ Key-in Commands
Desigr: |

Set |
Display: |

[T Adhos Atributes |
ak. | Cahicel |

5. Change the Item to a “Pavement Design” item.

6. Toggle on the “Pavement Design Parameters” and click the “Pavement Design
Parameters” button.

v Favement Dezign Parameters |

QK. | Cancel |

This will allow us to select the various sub layer items in out pavement design.
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7. Fill in the table by using the “Browse Item” icon and going to the “Pavement
Components” category located under the Pave Design 2 D&C Payltem that was
selected earlier.

g Parameters for Target ltem: Pave Design 2 M= E3

Edit

Jtem D Description

amp Azphalt

 ax %!
oK | MHCEI |

Select Pavement Dezign Items

23 Existinglnformation =]
3 Miscellaneous
£ Roadway
3 Slopes
23 Sidewalk
= Asphalt Pavement
339-1 Pavement [5")
= Pavement Design
Pave Dezsign 1 Pavement Design - Sq. vds.
Pave Design 2 Pavement Design - Tons
[ Pavement Components
:p Agphalt
Baze Baze
3 Drainage
£ Mizc

-

Select | Dare

8. Select each component by highlighting it then clicking the “Select” button.
Click “Done” when finished

9. Click “OK?” to close the Parameters dialog and click “OK” on the “Item
Modify” dialog.

10. Save the DDB file in the “Design and Computation Manager”.
Notice that the Pave Design 2 icon is different now.

,E Design and Computation Manager Hi=] E3

File Edit Settings Favorites Help

o~ id B donHE oD R

7 Sidewalk =
7 Azphalt Favement
= Pavement Design
Fave Design 1 Pavement Design - 5q. vds.
Pave Design 2 Pavement Design - Tons
[~ Pavement Components
azp Asphal
Base Base
3 Drainage
7 Misc -
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11. With the Pave Design 2 item highlighted, switch “Design & Computation
Manager” to the “Shape” mode.

gDesign and Computation Manager M=l E3
File Edit 3ettings Faworites Help

- 1d @ o S
&%)

£ Sidewalk =l
3 Asphalt Pavement
[ Pavement Design

Pave Design 1 Pavement Design - 5g. vds.

& Pave Desion 2 Pavement Design - Tong
[ Pavement Components
asp  Azphalt
Base Base
3 Drainage
3 Mizc -

This tool will create a shape in the symbology of the Pave Design 2 Payltem.
12. Set the Shape Tool settings as shown below.

£ Pave Design 2 Pavement Design - T___ [HJE B3
Exclusive vI |—
Radius: |5.DDDDD[ Tolerance; ID.1DDDD

13. Click “Draw” and then place a data point near the south end of the parking lot.
Next, place a data point in the middle of the building pad location. The shape is
created.

14. Switch the dialog as follows and data point in the South Access Road.
£ Pave Design 2 Pavement Design - T___ [HJE E3

Automatic vI —_—
D
Radius: [5.000000  Tolerance: [ 0.10000 e

15. Repeat this for Decab Street.
Now that the Pavement areas have been shaped we can calculate quantities.
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16. Switch to the Compute mode in the “Design & Computation Manager” and set

the “Plan Quantity Computation” dialog as follows.

g Plan Quantity Computation ME E
Job I Q. Eutents:  Active Degign File Vl Inzide Vl E@

Bazeline Reference

Mohe vI

¥ Hilite During Computation vI

Compute Quantities

17. Click the “Compute Quantities” button. Click in the “Parameters 1” row on

each item and set the depth in inches as shown.

E[anputalinn - Unknown Parameters

Farameter?

TH: 220
N: 722

3.000000 k

coe__|
18. Click “Resume Computation” to see the results.
£ Computation Results M= E3
[tem | Description | Quantity | Unit | E xpart |
Baze Baze 7100.3000 T™
asp Agzphalt 3550.2000 TH
Export Format: ke Report "II O Create Vl Export I
Fiuri | Fhases | DesignEstimate j Drizplay |

EXPORTING QUANTITIES TO VARIOUS FORMATS

We will take a look at how to export out the quantities that are computed to various

formats.

To view this portion of the lesson, press the play button.

PLAY

1. Close all dialogs and open the saved view (Utilities>Saved Views) named
“Export Quantities”. Then turn on the display of the Drainage and Water Sewer
reference files (File>Reference).

2.

Open “Design & Computation Manager” (Civil>Plans & Quantities>Design &

Computation Manager) and switch to the “Compute” mode.

© 2005 Bentley Systems, Incorporated
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3. Highlight the “Payltem” category and click the “Add Highlighted Folder to the
Collection” icon.

g Design and Computation Manager =] &3

File Edit 3ettings Faworites Help

5 id @ SER

@& CA\Data\Geo\SitehStandardshsite.ddb
23 Drafting Standards
1 AREAS/SHAPES

mm Payltem

(= Payltem

4. Click the “Compute Quantities” button.

£ Plan Quantity Computation M=
Job: I Q. Estents:  Active Deszign File Vl Inzide Vl E[E

Baseline Reference

MNone vI

¥ Hilite: During Computation "l | Compute Huantities I

5. Set the Base and Asphalt Parameters as we did previously.

E[anputalinn - Unknown Parameters
Itern | Description | Unit | Parameteri | Parametsr? |

Base Base TN 7220 E.000000

Rezurme Cormputation Cancel |

Click “Resume Computation”.
6. Select the “CSV by Item” report format.

E’ Computation Results M= E3
ltem | Description | uantity | Unit | Esport |
Baze Base 7100.3000 ™
azp Azphalt 3550, 2000 T
027-152-0100 &' Dia. B' Deep Wi MH 11.0000 E&
SR | e R—

ASiSlth Itern Repart - =
026-636-1970 “em A Ebplm 1.0000 EA
026-586-2850 =m 1 ae 319.8000 LF

DBEMS
5% By ltem %

b CSW By Element Eviile cav Q. Create | | Export I
Table

B I —————— 1 Phase: |DesignEstimate j Drizplay |

7. Key in afile name and click the “Export” button.
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8. Open the file with Microsoft Excel.
9. Change the Export Format to Table.

# Computation Results M=
Iterm | Description | Quantity | Uit | Export |
DesEofP Edge of Pavement 2B03.7000 LF
DesShwid Concrete Sidewalk, 4" thick, 29372 3502 SF
027-163-110 3% 3 Tupe 1 Grate Inlet 7.0000 Ed
027163310 4' Diamneter Circular Manhole 30000 Ea
027-162-2040  RCP 24" Clasz Il 34,2000 LF
027-162-2035  RCP 21" Class Il 20.3000 LF
027-162-2030  RCP 18" Clasz Il 909.5000 LF
Base Baze 7100.3000 ™
amp Azphalt 3RA0.2000 TH
027-152-0100 4 Dia. B' Deep 'Whw' MH 11.0000 Ed
0271621010 | B" PYC W astewater Line BE0.3000 LF
026-686-2050 12" Gate Yalve 1.0000 Ed
026-686-1970 4" Gate Yalve 1.0000 Ed
026-686-2850 | 4" PYC water Line 319.8000 LF

Ewport Format:  Table vI I cavfile.caw & Create vI @
Rur: | Phase: | DesignEstimate j Display

Place Quantity Table

SUMMARY

10. Click the “punch down arrow” next to the paintbrush to review the display
settings. Click the “paintbrush” to create the graphic table and then data point in
the file to place it.

The main points to remember are:

The PowerCivil Design & Computation Manager tool provides the way to extract
data from the design and use that data for construction cost estimates and
construction management.

You can create reports and/or extract information from PowerCivil into a usable and
customizable format.

For more video instruction please visit the following web page...
http://65.217.17.142/downloads/sitemodeler/ GEOPAK%20Site%20Modeler%20Training%20Videos.htm
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